Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

TLS Edge Provisioning Issues
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted May 13, 2022 - 20:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 19:56 UTC
Investigating
We're currently investigating performance issues with our TLS Edge Provisioning system. All other services are unaffected.
Posted May 13, 2022 - 19:17 UTC
This incident affected: Edge Cloud Services (TLS Provisioning).