Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Private key upload errors
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 20:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2020 - 20:43 UTC
Update
We are continuing to investigate this issue.
Posted Jun 25, 2020 - 20:29 UTC
Update
Fastly engineering is continuing to investigate an issue preventing new TLS private keys from being uploaded.
Posted Jun 25, 2020 - 20:00 UTC
Investigating
We are aware of a possible issue affecting private key uploads and are working to determine the scope and impact.
Posted Jun 25, 2020 - 19:37 UTC
This incident affected: Edge Cloud Services (TLS Provisioning).