Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Retroactive - Fastly Control Plane Performance Issues
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 15:03 UTC
Monitoring
Control plane systems have fully recovered and are currently functioning properly. Customers may have experienced slow response or intermittent timeouts on the Fastly App and API from 12:56 to 13:28 UTC
Posted Jul 14, 2020 - 13:45 UTC
Investigating
We are currently investigating performance issues that affected the availability of manage.fastly.com and our API. CDN delivery, stats aggregation, and all other data plane services are unaffected.
Posted Jul 14, 2020 - 13:32 UTC
This incident affected: Edge Cloud Services (Fastly API, Fastly Configuration Application).