Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

CDN Performance Impact
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 20:11 UTC
Monitoring
A fix has been implemented and Fastly is monitoring the results. Customers should be observing performance return to normal levels.
Posted Mar 09, 2021 - 19:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2021 - 19:08 UTC
Update
From 18:40-18:47 customers would have experienced an increase in 5xx errors and latency. Fastly incident response team is actively engaged and is working on mitigating the issue.
Posted Mar 09, 2021 - 19:00 UTC
Investigating
We are currently investigating this issue.
Posted Mar 09, 2021 - 18:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2021 - 18:35 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2021 - 18:31 UTC
Investigating
We're currently investigating potential impact to performance with our CDN services.
Posted Mar 09, 2021 - 18:02 UTC