Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

CDN Global Performance Impact
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted May 19, 2020 - 19:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Customers may have experienced an increase in 5XX errors and traffic impact globally, though the impact was most severe in LCY, HHN, BUR, BWI, SJC, DFW, FTY, and DCA from 17:49 to 18:04 UTC.
Posted May 19, 2020 - 18:32 UTC
Investigating
We're investigating elevated errors in Hong Kong (HKG). Various POPs in Europe may have also been momentarily affected from 17:50 to 17:52 UTC.
Posted May 19, 2020 - 18:06 UTC
This incident affected: Asia/Pacific (Hong Kong (HKG)).