Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Fastly Control Plane Performance Issues
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted May 21, 2020 - 14:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2020 - 11:06 UTC
Update
We are seeing coincident & intermittent purging issues for the moment.
Posted May 21, 2020 - 07:42 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 07:40 UTC
Investigating
We are currently investigating performance issues affecting the availability of manage.fastly.com and our API. CDN delivery, stats aggregation, and all other data plane services are unaffected.
Posted May 21, 2020 - 07:39 UTC
This incident affected: Edge Cloud Services (Fastly API, Fastly Configuration Application, Purging).