Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Purging System Performance Issues
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 06:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2020 - 06:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2020 - 05:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 18, 2020 - 05:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2020 - 04:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 18, 2020 - 01:12 UTC
Investigating
We're currently investigating possible performance issues with our URL and Surrogate Key purging services. All other services are unaffected.
Posted Sep 17, 2020 - 23:38 UTC
This incident affected: Edge Cloud Services (Purging).