Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Purging Systems Performance Issues
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 02:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2020 - 00:39 UTC
Update
We're currently investigating performance issues with our URL and Surrogate Key purging services. Purge All and all other services are unaffected.
Posted Aug 24, 2020 - 23:18 UTC
Investigating
We're currently investigating performance issues with our URL, Surrogate Key, and Purge All services. All other services are unaffected.
Posted Aug 24, 2020 - 23:10 UTC
This incident affected: Edge Cloud Services (Purging).