Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Billing Service Delay
Incident Report for Fastly
Resolved
All routine checks have been completed. Invoices can be accessed through standard methods.
Posted Aug 08, 2022 - 19:29 UTC
Update
Fastly Billing has completed our routine checks. As a result of these checks, customers who did not have charges in the month of July may have received an additional email notification confirming a $0.00 balance. There are no further actions to take in response to this notification.
Posted Aug 05, 2022 - 17:11 UTC
Monitoring
Fastly Billing is currently performing a series of routine checks on our billing process to ensure optimal accuracy for our August 1st billing cycle. As a result of these checks customers may experience a delay receiving their invoice.

There is no impact to production services or traffic.
Posted Aug 01, 2022 - 20:08 UTC
This incident affected: Fastly Systems (Billing System).