Fastly’s network has built-in redundancies and automatic failover routing to ensure optimal performance and uptime. But when a network issue does arise, we think our customers deserve clear, transparent communication so they can maintain trust in our service and our team. Notices will be posted here when we re-route traffic, upgrade hardware, or in the extremely rare case our network isn’t serving traffic. If you are experiencing issues and do not see a notice posted, please email support@fastly.com for assistance.

Configuration Propagation Performance Issues
Incident Report for Fastly
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 23:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2020 - 23:00 UTC
Identified
We're currently investigating performance issues with edge cloud configuration propagation. All other services are unaffected.
Posted Jul 24, 2020 - 21:42 UTC
Investigating
We are aware of a possible issue and are working to determine the scope and impact.
Posted Jul 24, 2020 - 21:39 UTC
This incident affected: Edge Cloud Services (Configuration Deployment).